Simplify BlockFetch type by eliminating ‘header’ type arg
Previously we had “ChainSync header block” but the header is in fact always just used for a “Point header”, which is really the same as a “Point block”, so the extra argument is unnecessary.
This gets used quite a few places, but it’s a mechanical change everywhere.
To maintain backward-compatibility I put a placeholder in the original
requires the two new files
and emits a deprecation warning.
This is generally needed for supporting providers other than AWS.